rm useless stuff

PA-RISC Apple Silicon is not on the roadmap

Signed-off-by: James Calligeros <jcalligeros99@gmail.com>
This commit is contained in:
James Calligeros 2024-06-24 15:38:12 +10:00
parent 5f53ff07c8
commit 12ada69969
Signed by: chadmed
GPG key ID: D43632D151F77960
378 changed files with 0 additions and 197455 deletions

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

View file

@ -1,67 +0,0 @@
---- a/releases/kconfig/amd64/livegui-amd64-5.15.23.config
-+++ b/releases/kconfig/amd64/livegui-amd64-5.15.23.config
@@ -2395,8 +2395,8 @@
CONFIG_ZRAM_DEF_COMP="lzo-rle"
# CONFIG_ZRAM_WRITEBACK is not set
# CONFIG_ZRAM_MEMORY_TRACKING is not set
-CONFIG_BLK_DEV_LOOP=m
-CONFIG_BLK_DEV_LOOP_MIN_COUNT=0
+CONFIG_BLK_DEV_LOOP=y
+CONFIG_BLK_DEV_LOOP_MIN_COUNT=4
# CONFIG_BLK_DEV_CRYPTOLOOP is not set
CONFIG_BLK_DEV_DRBD=m
# CONFIG_DRBD_FAULT_INJECTION is not set
@@ -6874,7 +6874,7 @@
#
# also be needed; see USB_STORAGE Help for more info
#
-CONFIG_USB_STORAGE=m
+CONFIG_USB_STORAGE=y
# CONFIG_USB_STORAGE_DEBUG is not set
CONFIG_USB_STORAGE_REALTEK=m
CONFIG_REALTEK_AUTOPM=y
@@ -8715,7 +8715,7 @@
CONFIG_CUSE=m
CONFIG_VIRTIO_FS=m
CONFIG_FUSE_DAX=y
-CONFIG_OVERLAY_FS=m
+CONFIG_OVERLAY_FS=y
# CONFIG_OVERLAY_FS_REDIRECT_DIR is not set
CONFIG_OVERLAY_FS_REDIRECT_ALWAYS_FOLLOW=y
# CONFIG_OVERLAY_FS_INDEX is not set
@@ -8737,7 +8737,7 @@
#
# CD-ROM/DVD Filesystems
#
-CONFIG_ISO9660_FS=m
+CONFIG_ISO9660_FS=y
CONFIG_JOLIET=y
CONFIG_ZISOFS=y
CONFIG_UDF_FS=m
@@ -8748,7 +8748,7 @@
#
CONFIG_FAT_FS=m
CONFIG_MSDOS_FS=m
-CONFIG_VFAT_FS=m
+CONFIG_VFAT_FS=y
CONFIG_FAT_DEFAULT_CODEPAGE=437
CONFIG_FAT_DEFAULT_IOCHARSET="ascii"
# CONFIG_FAT_DEFAULT_UTF8 is not set
@@ -8756,7 +8756,7 @@
CONFIG_EXFAT_FS=m
CONFIG_EXFAT_DEFAULT_IOCHARSET="utf8"
# CONFIG_NTFS_FS is not set
-CONFIG_NTFS3_FS=m
+CONFIG_NTFS3_FS=y
# CONFIG_NTFS3_64BIT_CLUSTER is not set
CONFIG_NTFS3_LZX_XPRESS=y
CONFIG_NTFS3_FS_POSIX_ACL=y
@@ -8825,7 +8825,7 @@
CONFIG_CRAMFS=m
CONFIG_CRAMFS_BLOCKDEV=y
# CONFIG_CRAMFS_MTD is not set
-CONFIG_SQUASHFS=m
+CONFIG_SQUASHFS=y
# CONFIG_SQUASHFS_FILE_CACHE is not set
CONFIG_SQUASHFS_FILE_DIRECT=y
# CONFIG_SQUASHFS_DECOMP_SINGLE is not set

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

File diff suppressed because it is too large Load diff

View file

@ -1,2 +0,0 @@
CFLAGS="${CFLAGS} -D_FILE_OFFSET_BITS=64"
CXXFLAGS="${CXXFLAGS} -D_FILE_OFFSET_BITS=64"

View file

@ -1 +0,0 @@
FEATURES="-pid-sandbox -network-sandbox -ipc-sandbox -sandbox -usersandbox"

View file

@ -1 +0,0 @@
FEATURES="-pid-sandbox -network-sandbox -ipc-sandbox"

View file

@ -1,35 +0,0 @@
post_src_unpack() {
if use arm64 || use ppc64; then
einfo "hooked by ${BASH_SOURCE[0]} in ${FUNCNAME[0]}"
local patchfile
patchfile="${PORTAGE_CONFIGROOT%/}/etc/portage/patches/genkernel-ppc64-iso.patch"
if [[ -f ${patchfile} ]]; then
einfo "found genkernel patch for bug https://bugs.gentoo.org/796272"
cd "${S}" || die
eapply "${patchfile}"
else
ewarn "no genkernel patch found, skipping hook"
fi
fi
}
post_pkg_postinst() {
einfo "hooked by ${BASH_SOURCE[0]} in ${FUNCNAME[0]}"
einfo "cleaning up bug https://bugs.gentoo.org/796272 workarounds"
# cleanup after ourselves, we don't want workarounds shipped to users
# and don't want updating all the spec files with new removal directives.
local envfile patchfile
envfile="${PORTAGE_CONFIGROOT%/}/etc/portage/env/sys-kernel/genkernel"
patchfile="${PORTAGE_CONFIGROOT%/}/etc/portage/patches/genkernel-ppc64-iso.patch"
local _x
for _x in "${envfile}" "${patchfile}"; do
if [[ -f ${_x} ]]; then
rm -vf "${_x}"
fi
done
rmdir -v --ignore-fail-on-non-empty "${PORTAGE_CONFIGROOT%/}/etc/portage/env/sys-kernel"
rmdir -v --ignore-fail-on-non-empty "${PORTAGE_CONFIGROOT%/}/etc/portage/env"
rmdir -v --ignore-fail-on-non-empty "${PORTAGE_CONFIGROOT%/}/etc/portage/patches"
}

View file

@ -1,4 +0,0 @@
sys-block/lsiutil
sys-block/megarc
sys-fs/dislocker
sys-fs/ext3grep

View file

@ -1 +0,0 @@
*/* releng/qemu

View file

@ -1 +0,0 @@
dev-util/cmake releng/forcelfs

View file

@ -1 +0,0 @@
sys-libs/glibc releng/nosandbox

View file

@ -1,3 +0,0 @@
# Allow linux-firmware and other required packages in @BINARY-REDISTRIBUTABLE
# license group
*/* @BINARY-REDISTRIBUTABLE

View file

@ -1,5 +0,0 @@
# preemptively...
# new glibc tends to lead to trouble with sandbox (and qemu),
# especially for the unstable arches
#
>=sys-libs/glibc-2.40

View file

@ -1,2 +0,0 @@
# force using rust-bin (this affects only "desktop stages")
dev-lang/rust

View file

@ -1,3 +0,0 @@
dev-libs/libpcre2 jit
mail-mta/ssmtp mta
sys-apps/busybox -static

View file

@ -1 +0,0 @@
dev-libs/libpcre2 pcre32

View file

@ -1,4 +0,0 @@
net-fs/cifs-utils -acl -ads
sys-libs/ntdb python
sys-libs/tdb python
sys-libs/tevent python

View file

@ -1 +0,0 @@
sys-apps/util-linux static-libs

View file

@ -1 +0,0 @@
sys-kernel/gentoo-sources symlink

View file

@ -1,5 +0,0 @@
# required by sys-libs/libselinux-2.7
dev-libs/libpcre static-libs
# required by dev-vcs/git
dev-libs/libpcre2 jit

View file

@ -1 +0,0 @@
sys-kernel/linux-firmware savedconfig

View file

@ -1,2 +0,0 @@
*/* lvm
sys-fs/lvm2 thin

View file

@ -1 +0,0 @@
dev-libs/libgcrypt -asm

View file

@ -1,5 +0,0 @@
# There is a circular dependency between sys-libs/libcap[pam] and
# sys-libs/pam[filecaps]. Since the livecd is configured to automatically log
# in as root, caps are not useful, so just disable USE=filecaps.
*/* -filecaps

View file

@ -1 +0,0 @@
sys-auth/pambase -passwdqc

View file

@ -1 +0,0 @@
net-wireless/wpa_supplicant tkip wps

View file

@ -1,41 +0,0 @@
diff --git a/Makefile.pre.in b/Makefile.pre.in
index 4924dedc35..75eb66be3c 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -1432,30 +1432,30 @@ libinstall: build_all $(srcdir)/Modules/xxmodule.c
fi
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST) -f \
+ -d $(LIBDEST) -f \
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
$(DESTDIR)$(LIBDEST)
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi -O $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST) -f \
+ -d $(LIBDEST) -f \
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
$(DESTDIR)$(LIBDEST)
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi -OO $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST) -f \
+ -d $(LIBDEST) -f \
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
$(DESTDIR)$(LIBDEST)
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST)/site-packages -f \
+ -d $(LIBDEST)/site-packages -f \
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi -O $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST)/site-packages -f \
+ -d $(LIBDEST)/site-packages -f \
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi -OO $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST)/site-packages -f \
+ -d $(LIBDEST)/site-packages -f \
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt

View file

@ -1,41 +0,0 @@
diff --git a/Makefile.pre.in b/Makefile.pre.in
index 4924dedc35..75eb66be3c 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -1432,30 +1432,30 @@ libinstall: build_all $(srcdir)/Modules/xxmodule.c
fi
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST) -f \
+ -d $(LIBDEST) -f \
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
$(DESTDIR)$(LIBDEST)
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi -O $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST) -f \
+ -d $(LIBDEST) -f \
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
$(DESTDIR)$(LIBDEST)
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi -OO $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST) -f \
+ -d $(LIBDEST) -f \
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
$(DESTDIR)$(LIBDEST)
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST)/site-packages -f \
+ -d $(LIBDEST)/site-packages -f \
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi -O $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST)/site-packages -f \
+ -d $(LIBDEST)/site-packages -f \
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi -OO $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST)/site-packages -f \
+ -d $(LIBDEST)/site-packages -f \
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt

View file

@ -1,41 +0,0 @@
diff --git a/Makefile.pre.in b/Makefile.pre.in
index 4924dedc35..75eb66be3c 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -1432,30 +1432,30 @@ libinstall: build_all $(srcdir)/Modules/xxmodule.c
fi
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST) -f \
+ -d $(LIBDEST) -f \
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
$(DESTDIR)$(LIBDEST)
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi -O $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST) -f \
+ -d $(LIBDEST) -f \
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
$(DESTDIR)$(LIBDEST)
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi -OO $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST) -f \
+ -d $(LIBDEST) -f \
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
$(DESTDIR)$(LIBDEST)
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST)/site-packages -f \
+ -d $(LIBDEST)/site-packages -f \
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi -O $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST)/site-packages -f \
+ -d $(LIBDEST)/site-packages -f \
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi -OO $(DESTDIR)$(LIBDEST)/compileall.py \
- -j0 -d $(LIBDEST)/site-packages -f \
+ -d $(LIBDEST)/site-packages -f \
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt

View file

@ -1,47 +0,0 @@
From 628e1a30b384a900cf7095cf86441fed7a0300dc Mon Sep 17 00:00:00 2001
From: Georgy Yakovlev <gyakovlev@gentoo.org>
Date: Fri, 14 May 2021 22:05:33 -0700
Subject: [PATCH] defaults/initrd.scripts: don't skip top level devices with
partitions
ppc64 media should be mounted as /dev/sdX, not as /dev/sdX1
this loop was skipping /dev/sdX if /dev/sdX1 is present.
Bug: https://bugs.gentoo.org/796272
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
---
defaults/initrd.scripts | 18 ------------------
1 file changed, 18 deletions(-)
diff --git a/defaults/initrd.scripts b/defaults/initrd.scripts
index 5ec8adb..bfc36cf 100644
--- a/defaults/initrd.scripts
+++ b/defaults/initrd.scripts
@@ -178,24 +178,6 @@ findmediamount() {
# Check for a block device to mount
if [ -b "${x}" ]
then
- skip=0
- bsn=$(basename "${x}")
- #
- # If disk and it has at least one partition, skip.
- # We use /sys/block/${bsn}/${bsn}[0-9]* to make sure that we
- # don't skip device mapper devices. Even the craziest scenario
- # deserves a fair chance.
- #
- # shellcheck disable=SC2045
- for part in $(ls /sys/block/${bsn}/${bsn}*[0-9]* 2>/dev/null)
- do
- skip=1
- break;
- done
- if [ ${skip} -eq 1 ]
- then
- continue
- fi
good_msg "Attempting to mount media: ${x}" ${CRYPT_SILENT}
CDROOT_TYPE=$(determine_fs "${x}" "${CDROOT_TYPE}")
--
2.31.1

View file

@ -1,3 +0,0 @@
sys-block/lsiutil
sys-block/megarc
sys-fs/dislocker

View file

@ -1 +0,0 @@
net-wireless/broadcom-sta

View file

@ -1,2 +0,0 @@
# Need newest genkernel for x86 busybox fixes
=sys-kernel/genkernel-4.3.14

View file

@ -1,3 +0,0 @@
# Allow linux-firmware and other required packages in @BINARY-REDISTRIBUTABLE
# license group
*/* @BINARY-REDISTRIBUTABLE

View file

@ -1,5 +0,0 @@
# preemptively...
# new glibc tends to lead to trouble with sandbox (and qemu),
# especially for the unstable arches
#
>=sys-libs/glibc-2.40

View file

@ -1,2 +0,0 @@
# force using rust-bin (this affects only "desktop stages")
dev-lang/rust

View file

@ -1,3 +0,0 @@
dev-libs/libpcre2 jit
mail-mta/ssmtp mta
sys-apps/busybox -static

View file

@ -1 +0,0 @@
dev-libs/libpcre2 pcre32

View file

@ -1,4 +0,0 @@
net-fs/cifs-utils -acl -ads
sys-libs/ntdb python
sys-libs/tdb python
sys-libs/tevent python

View file

@ -1 +0,0 @@
sys-apps/util-linux static-libs

View file

@ -1 +0,0 @@
sys-kernel/gentoo-sources symlink

View file

@ -1 +0,0 @@
sys-kernel/linux-firmware savedconfig

View file

@ -1 +0,0 @@
*/* lvm

View file

@ -1,5 +0,0 @@
# There is a circular dependency between sys-libs/libcap[pam] and
# sys-libs/pam[filecaps]. Since the livecd is configured to automatically log
# in as root, caps are not useful, so just disable USE=filecaps.
*/* -filecaps

View file

@ -1 +0,0 @@
sys-auth/pambase -passwdqc

View file

@ -1 +0,0 @@
net-wireless/wpa_supplicant tkip wps

File diff suppressed because it is too large Load diff

View file

@ -1,57 +0,0 @@
#!/bin/bash
# This script operates on a new vanilla linux-firmware savedconfig file to create
# an updated pruned file for minimal livecds. It will directly replace the
# linux-firwmare file in this directory.
#
# Some firmware types we prune include GPU firmwares, DVB firmwares, and unusually
# large firmwares for enterprise 10G+ NICs.
# Example usage:
# ./prune_firmwares.sh /etc/portage/savedconfig/sys-kernel/linux-firmware-20230515
# git add . && git commit -sS
echo "# $(git config user.name) <$(git config user.email)> ($(date +%Y-%m-%d))" > linux-firmware
echo "# Last updated for $(basename ${1})" >> linux-firmware
sed -e's/^a300/#a300/' \
-e 's/^amd/#amd/' \
-e 's/^airoha/#airoha/' \
-e 's/^atusb/#atusb/' \
-e 's/^av7110/#av7110/' \
-e 's/^cadence/#cadence/' \
-e 's/^cavium/#cavium/' \
-e 's/^cmmb/#cmmb/' \
-e 's/^dabusb/#dabusb/' \
-e 's/^dsp56k/#dsp56k/' \
-e 's/^dvb/#dvb/' \
-e 's/^emi26/#emi26/' \
-e 's/^ene-/#ene-/' \
-e 's/^f2255/#f2255/' \
-e 's/^go7007/#go7007/' \
-e 's/^hfi1/#hfi1/' \
-e 's/^i915/#i915/' \
-e 's%^intel/vsc%#intel/vsc%' \
-e 's%^intel/ipu%#intel/ipu%' \
-e 's/^isdbt/#isdbt/' \
-e 's/^keyspan/#keyspan/' \
-e 's/^liquidio/#liquidio/' \
-e 's/^matrox/#matrox/' \
-e 's/^mellanox/#mellanox/' \
-e 's/^moxa/#moxa/' \
-e 's/^mts/#mts/' \
-e 's/^netronome/#netronome/' \
-e 's/^nvidia/#nvidia/' \
-e 's/^qat/#qat/' \
-e 's/^qed/#qed/' \
-e 's/^r128/#r128/' \
-e 's/r8a779x/#r8a779x/' \
-e 's/^radeon/#radeon/' \
-e 's/^s5p-mfc/#s5p-mfc/' \
-e 's/^sms1/#sms1/' \
-e 's/^sxg/#sxg/' \
-e 's/^tdmb/#tdmb/' \
-e 's/^tlg/#tlg/' \
-e 's/^usbdux/#usbdux/' \
-e 's/^v4l-/#v4l-/' \
${1} >> linux-firmware

View file

@ -1,2 +0,0 @@
CFLAGS="${CFLAGS} -D_FILE_OFFSET_BITS=64"
CXXFLAGS="${CXXFLAGS} -D_FILE_OFFSET_BITS=64"

View file

@ -1 +0,0 @@
FEATURES="-pid-sandbox -network-sandbox -ipc-sandbox -sandbox -usersandbox"

View file

@ -1 +0,0 @@
FEATURES="-pid-sandbox -network-sandbox -ipc-sandbox"

View file

@ -1 +0,0 @@
MAKEOPTS="-j1"

View file

@ -1 +0,0 @@
*/* releng/qemu

View file

@ -1 +0,0 @@
dev-util/cmake releng/forcelfs

View file

@ -1 +0,0 @@
sys-libs/glibc releng/nosandbox

View file

@ -1,4 +0,0 @@
# this is needed for qemu-m68k, otherwise make aborts with
# "The futex facility returned an unknown value"
dev-lang/python releng/singleproc
dev-python/lxml releng/singleproc

View file

@ -1,5 +0,0 @@
# preemptively...
# new glibc tends to lead to trouble with sandbox (and qemu),
# especially for the unstable arches
#
>=sys-libs/glibc-2.40

View file

@ -1,2 +0,0 @@
# force using rust-bin (this affects only "desktop stages")
dev-lang/rust

Some files were not shown because too many files have changed in this diff Show more